Page 1 of 1

Carberry sudden death issue as same as below

PostPosted: Thu Jun 14, 2018 5:34 am
by JSLEE
I also have same symptom as below, but a little bit faster.

I only plugged 12V pwr, GND, 12V IGN in to Carberry, and Mouse/Keyboard/HDMI in PI.
It turns on, booted but suddenly shutdown around 30sec after boot-up.

I tried plugged 12V pwr, GND, 12V IGN in to Carberry, and not any connection on PI.
It turns on, booted but suddenly shutdown exactly same as upper.

I tried plugged 12V pwr, GND, 12V IGN in to another Carberry board, and not any connection on PI.
It turns on, booted but suddenly shutdown exactly same as upper.

I tried only Raspberry PI OS, no carberry daemon and start carberry also.
In this case, PI shutdowned because Carberry Board stops power supply.

In addition, even thougt I do not plug any SD card and start Carberry power supply with PI connection,
caberry halts.

Last, I plugged out PI and use carberry board only and start Carberry power on, then Carberry halts as below.
Carberry board 1 : halted after 85 sec from power/IGN engaged.
Carberry board 2 : haled after 83 sec from power/IGN engaged.

With proper PI and carbian, Carberry halts as below
Carberry board 1 : halted after 33 sec from power/IGN engaged.
Carberry board 2 : halted after 34 sec from power/IGN engaged.

While Carberry shuts down with proper carbian, it always set Raspberry PI Pin 13 to GND.

I totally do not understand this situation. What can cause this?
I used 2 PI B boards, and 2 Carberry boards, and their symptom are exactly same.
I really want to debug Carberry itself, but I cannot.

I think IGN is constantly engaged to Carberry.
Can you show me what else Carberry sets shutdown except IGN, and what else can I test?

Re: Carberry sudden death issue as same as below

PostPosted: Wed Oct 10, 2018 5:06 pm
by PAOLOPED
Hi,
Ok a little explanation is necessary to understand how Carberry manages power.
When Carberry swiches on, will wait for communication by carberry daemon on its UART, if carberry daemon doesn’t start or is not able to communicate with Carberry UART, power will be removed.
Which distro did you use?

let me know, thanks