Carberry Forum

Carberry Development Forum
It is currently Wed Aug 04, 2021 9:48 pm

All times are UTC + 2 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: UART Timeout
PostPosted: Wed Oct 03, 2018 11:50 am 
Offline

Joined: Wed Oct 03, 2018 11:43 am
Posts: 1
Hello,

Firstly I tested "Carberry - OBD Info Panel - V2.0 - Jessie" on a RPI 3B, I can see the gauge but error "CAN BUS not active" (or similar), So I checked the carberry's daemon but it not launch (UART timeout).

So I tested with "Carbian - Stretch - V2.0", daemon seem to launch (ps aux is ok), If I launch "/home/pi/carberry_d/carberry" no error, but I try to upgrade the firmware :

Code:
pi@raspberrypi:~/reflash_1.0 $ ./reflash Carberry_1.19.asc
Connecting Carberry Server...
Carberry Ready
Opening upgrade file...
Recv Error!
Probing boot mode...Recv Error!

Entering Carberry in boot mode...Recv Error!

Error in REFLASH command


And the log of the "/home/pi/carberry_d/carberry" :

Code:
pi@raspberrypi:~/reflash_1.0 $ /home/pi/carberry_d/carberry
Carberry Started
UART PORT will be -> /dev/ttyS0
Host 127.0.0.1 connected on socket #6
ERROR - UART Timeout!
ERROR - UART Timeout!
ERROR - UART Timeout!
ERROR - UART Timeout!
ERROR - UART Timeout!


Do you know where is the problem ?
Thanks for your help.


Top
 Profile  
 
 Post subject: Re: UART Timeout
PostPosted: Tue Dec 18, 2018 10:20 am 
Offline
Site Admin

Joined: Mon May 12, 2014 4:10 pm
Posts: 40
Hi,
Just to be sure... are you powering all system from micro-usb or from 12V?

Please consider you need to power all system always from Carberry +12V and not even more from +5V microusb.


Top
 Profile  
 
 Post subject: Re: UART Timeout
PostPosted: Sun Jul 11, 2021 10:12 am 
Offline

Joined: Sun Jul 11, 2021 9:59 am
Posts: 2
Hi,

I have a similar problem :

Connection with putty and serial port : OK sending command works fine (AT return OK, ECHO ON etc)

Connection with socket, adress 127.0.0.1 port 7070, sending "ERROR - UART Timeout!" for each request.

Looking if daemon is ok with ps aux = OK process carberry_d is running
Looking if daemon is listening on port 7070 (sudo netstat - plunt) : ok , tcp local adress : 0.0.0.0:7070 , distant adresss : 0.0.0.0 Status LISTEN Progam carberry

What can I test or what problem could it be ?

Second question : How to test sending and receiving message by connecting channel 1 and 2 ? I tried to connect green to yellow green and white to yellow white, but if I send something (with putty) to channel 1 I don't see any RX message, nothing at all.

Rgds


Top
 Profile  
 
 Post subject: Re: UART Timeout
PostPosted: Sun Jul 11, 2021 2:39 pm 
Offline

Joined: Sun Jul 11, 2021 9:59 am
Posts: 2
Find the problem :

In PI4 , you must have "dtoverlay=disable-bt" in /boot/config.txt

Works fine, now

If anyone has the answer for testing communication between channel 1 and channel 2...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group