Carberry Forum

Carberry Development Forum
It is currently Thu Jun 04, 2020 2:11 pm

All times are UTC + 2 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: uart communication
PostPosted: Thu Dec 27, 2018 3:35 pm 
Offline

Joined: Thu Dec 27, 2018 3:00 pm
Posts: 1
hi guys,

so after a bit of hovering i finally bought the carberry board for a side project of mine.

as the name suggests i"ve got a VW buggy with a 1641cc type 1 motor cranking out about 90 hp in a 600 kg car running on megasquirt ms3 and its been the best upgrade I've ever on to the buggy.

one of my problems is that the front wheel circumference is 13% smaller than the stock bug wheels and so the speedo reads 13% to high.
the other is that when on holiday in the bug i take an old laptop to troubleshoot just in case and there's better solutions for that to

so got an rpi3b, the 7inch official screen and now the carberry and a GPS module, just cause.
the main function of the carberry will be the shutdown demon and the powersuply part of it.
tunerstudio works like a charm on the pi and that ill give my display including VSS and hopefully the tank level, i don't mind the 60 seconds of boot time as its not a dayly

the can is nice to have and the rtc and gpio may come in handy one day but for now i just want the shutdown to work.
the board was made 11/18 and has fwp066unun19 according to the sticker.

if i try minicom 'ing into the board i get gobbledegook or half the message i was expecting.
using the following settings:
port /dev/ttyS0 lockfile /var/lock
baud 115200 8n1
no flow control and the modem and dialling as per minicom wiki, setting A true I set to blank

if i run dmesg | grep -e tty i get the last line saying :

3f215040.serial: ttyS0 at mmio 0x0 (irq 166, base baud = 31250000) is a 16550.

so i tried some other bauds and the gobbledegook disappears completely.

what am i doing wrong?
its on the bench at the moment powered by a lab psu and nothing other than the display connected.


Top
 Profile  
 
 Post subject: Re: uart communication
PostPosted: Sun Feb 09, 2020 7:52 am 
Offline

Joined: Sun Feb 09, 2020 7:47 am
Posts: 1
Hello! So. did you figure it out ?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group